Services have remained stable for the past 3 hours. This issue is now resolved.
Posted Sep 30, 2024 - 17:21 EDT
Monitoring
Service alarms are clearing. All services should be 100% operational.
Posted Sep 30, 2024 - 14:09 EDT
Update
Inbound and outbound calling services should now be restored. There may be a slight delay on inbound call completions. Engineering is continuing to work on resolving the delay.
Posted Sep 30, 2024 - 13:21 EDT
Update
Inbound services are restored, but there is still an issue with outbound calling. Engineering is working to resolve the issue.
Posted Sep 30, 2024 - 13:00 EDT
Investigating
We are currently investigating an issue with upstream carrier impacting voice services. Outbound calling is impacted. Engineering is working to resolve the issue.
Posted Sep 30, 2024 - 12:34 EDT
This incident affected: Hosted PBX Platform, Voice Portal, Fiber Network, Voice - Outbound, MyPhone Portal, UCLinks with Webex, and Express Admin Portal.