Intermittent Fiber Outages

Incident Report for Universal Connectivity

Resolved

Network Analysts and Tier III engineers were engaged and services are now reported as stable as of approx. 12:43 PM ET. We will continue our investigation into the cause.
Posted Oct 02, 2025 - 13:27 EDT

Update

Services appear to have stabilized. We're still investigating root cause with upstream carrier.
Posted Oct 02, 2025 - 12:17 EDT

Investigating

We are investigating an incident resulting in intermittent fiber outages. We will provide updates as they become available.
Posted Oct 02, 2025 - 11:33 EDT
This incident affected: Fiber Network.