Fiber cut resulting in interruption of internet service for some locations

Incident Report for Universal Connectivity

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 15:18 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 10, 2025 - 14:29 EDT

Monitoring

Fiber has been repaired and service is restored. We will continue to monitor.
Posted Apr 10, 2025 - 14:28 EDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 10, 2025 - 14:07 EDT

Identified

The fiber cut has been located and crew is working on the repair. Estimated time for service restoration is approximately 30 minutes.
Posted Apr 10, 2025 - 14:05 EDT

Investigating

We are investigating an interruption in internet service due to an apparent fiber cut. This issue is affecting a few locations. We will update with status as we learn more.
Posted Apr 10, 2025 - 13:59 EDT
This incident affected: Fixed Wireless Network.